use strict;
my $str = '***ÄNDERUNG ***
NEU:11.04.15 DUS AB 2646 13:15 16:25
18.04.15 FNC DUS AB 2647 17:15
FNC027 PESTANA CARLTON MADEIRA 9004-531 FUNCHAL
1 DO-MEERBLICK F
F365474 HERR PETERS, HANS O 03.01.15
LANGZEITERMÄSSIGUNG 10%
SPO-JAN_SALES 20%
FRÜHBUCHER 10%
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
Zimmer in ruhiger Lage
(unverbindlicher Kundenwunsch)
NEU:
F365474 FRAU PETERS, ULRIKE O 03.01.15';
my $regex = qr/(\d{2}\.\d{2}\.\d{2})(?:\s+(\w{3}))?\s+\w{3}\s+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n)\s+(\d{2}\.\d{2}\.\d{2}).+(\w{2}\s\d{4})\s+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}