# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}\.\d{2}\.\d{2})(?:\s+(\w{3}))?\s+\w{3}\s+(\w{2}\s\d{4}).+(\d{2}:\d{2}\n)\s+(\d{2}\.\d{2}\.\d{2}).+(\w{2}\s\d{4})\s+(\d{2}:\d{2}\n).+((FNC|PXO)\d{3})"
test_str = ("***ÄNDERUNG ***\n"
"NEU:11.04.15 DUS AB 2646 13:15 16:25\n"
" 18.04.15 FNC DUS AB 2647 17:15\n"
" FNC027 PESTANA CARLTON MADEIRA 9004-531 FUNCHAL\n"
" 1 DO-MEERBLICK F\n"
"F365474 HERR PETERS, HANS O 03.01.15\n"
"LANGZEITERMÄSSIGUNG 10%\n"
"SPO-JAN_SALES 20%\n"
"FRÜHBUCHER 10%\n"
"INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
"FLUGHAFEN\n"
"Zimmer in ruhiger Lage\n"
"(unverbindlicher Kundenwunsch)\n"
"NEU:\n"
"F365474 FRAU PETERS, ULRIKE O 03.01.15")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.