#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "</table>.*"
Local $sString = "\"id=\"fruit_info\">" & @CRLF & _
"<tr class='thead'>" & @CRLF & _
"<th colspan=2>Strawberries</th></table>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"<tr class"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")