$re = '~</table>.*~';
$str = '\\"id=\\"fruit_info\\">
<tr class=\'thead\'>
<th colspan=2>Strawberries</th></table>
</tr>
</table>
<tr class';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);