package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/[0-9]+\/)|([0-9]+$)`)
var str = `upload/.bes/.ur/13
upload/.tables/.u23ser/15
upload/.tles2/.uer/11
upload/1.tales/.user2/01
upload/23/21
upload/.tables/00/31
upload/6/.uer/51`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}