$re = '/(\/[0-9]+\/)|([0-9]+$)/m';
$str = 'upload/.bes/.ur/13
upload/.tables/.u23ser/15
upload/.tles2/.uer/11
upload/1.tales/.user2/01
upload/23/21
upload/.tables/00/31
upload/6/.uer/51';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);