package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bDOMAIN(?:Y|A)?\b`)
var str = `DOMAIN DOMAINY DOMAINA
DOMAINX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}