$re = '/\bDOMAIN(?:Y|A)?\b/';
$str = 'DOMAIN DOMAINY DOMAINA
DOMAINX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);