re = /\/\/ CDY function call '{}'\n/m
str = ' // CDY function call \'handleVal1\'
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end