$re = '/[\s,.\'-]{2,}|[\s.]/';
$str = 'She said - \'That\'ll be all, Two-Fry.\'руский and ไทอ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);