using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"interface GigabitEthernet1\/(1[2-9]|[1-2][0-1]).*\n(.*\n)*.* description \*\* Unused Port \*\*.*\n(.*\n)*.* switchport access vlan 1002.*\n(.*\n)*.* switchport mode access.*\n(.*\n)*.* switchport port-security.*\n(.*\n)*.* switchport port-security mac-address sticky.*\n(.*\n)*.* shutdown.*\n(.*\n)*.* no cdp enable.*\n(.*\n)*.* spanning-tree portfast
";
string substitution = @"";
string input = @"interface GigabitEthernet1/12
description ** Unused Port **
switchport access vlan 1002
switchport mode access
switchport port-security
switchport port-security mac-address sticky
shutdown
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet1/13
description ** Unused Port **
switchport access vlan 1002
switchport mode access
switchport port-security
switchport port-security mac-address sticky
shutdown
no cdp enable
spanning-tree portfast
!
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}