import re
regex = re.compile((r"interface GigabitEthernet1\/(1[2-9]|[1-2][0-1]).*\n(.*\n)*.* description \*\* Unused Port \*\*.*\n(.*\n)*.* switchport access vlan 1002.*\n(.*\n)*.* switchport mode access.*\n(.*\n)*.* switchport port-security.*\n(.*\n)*.* switchport port-security mac-address sticky.*\n(.*\n)*.* shutdown.*\n(.*\n)*.* no cdp enable.*\n(.*\n)*.* spanning-tree portfast\n"))
test_str = ("interface GigabitEthernet1/12\n"
" description ** Unused Port **\n"
" switchport access vlan 1002\n"
" switchport mode access\n"
" switchport port-security\n"
" switchport port-security mac-address sticky\n"
" shutdown\n"
" no cdp enable\n"
" spanning-tree portfast\n"
"!\n"
"interface GigabitEthernet1/13\n"
" description ** Unused Port **\n"
" switchport access vlan 1002\n"
" switchport mode access\n"
" switchport port-security\n"
" switchport port-security mac-address sticky\n"
" shutdown\n"
" no cdp enable\n"
" spanning-tree portfast\n"
"!\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)