using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!\<span\sclass=""the-image""\>)\<img[\sA-Z""\-_=\/.\d]*\/\>)(?!\<\/span\>)";
string input = @"<span clasds=""the-image""><img src=""123"" /></span>
<img src=""123/4."" />
<span class=""the-image""><img src=""123"" /></span>
<img src=""123/4."" />
<span class=""the-image""><img src=""123"" /></span>
<span class=""the-image""><img src=""123"" /></span>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}