$re = '/((?!\<span\sclass="the-image"\>)\<img[\sA-Z"\-_=\/.\d]*\/\>)(?!\<\/span\>)/i';
$str = '<span clasds="the-image"><img src="123" /></span>
<img src="123/4." />
<span class="the-image"><img src="123" /></span>
<img src="123/4." />
<span class="the-image"><img src="123" /></span>
<span class="the-image"><img src="123" /></span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);