# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(http:\/\/|https:\/\/)?[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(:80|:443)?$|^(http:\/\/|https:\/\/)?\[[0-9a-fA-F:]+\](:80|:443)?$|^(http:\/\/|https:\/\/)?[0-9a-fA-F:]+(:80|:443)?$"
test_str = ("http://example.com\n"
"https://example.com\n"
"http://example.com:80\n"
"https://example.com:80\n"
"http://example.com:443\n"
"https://example.com:443\n"
"example.com:80\n"
"example.com:443\n"
"http://10.255.255.1\n"
"https://10.255.255.1\n"
"http://10.255.255.1:80\n"
"https://10.255.255.1:80\n"
"http://10.255.255.1:443\n"
"https://10.255.255.1:443\n"
"10.255.255.1:80\n"
"10.255.255.1:443\n"
"http://8.8.8.8\n"
"https://8.8.8.8\n"
"http://8.8.8.8:80\n"
"https://8.8.8.8:80\n"
"http://8.8.8.8:443\n"
"https://8.8.8.8:443\n"
"8.8.8.8:80\n"
"8.8.8.8:443\n"
"8.8.8.8\n"
"http://[fd00::1]\n"
"https://[fd00::1]\n"
"http://[fd00::1]:80\n"
"https://[fd00::1]:80\n"
"http://[fd00::1]:443\n"
"https://[fd00::1]:443\n"
"[fd00::1]:80\n"
"[fd00::1]:443\n"
"fd00::1:80\n"
"fd00::1:443\n"
"[fd00::1]\n"
"fd00::1\n"
"http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]\n"
"https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]\n"
"http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:80\n"
"https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:80\n"
"http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:443\n"
"https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:443\n"
"2001:0db8:85a3:0000:0000:8a2e:0370:7334:443\n"
"http://[2001:db8::1]\n"
"https://[2001:db8::1]\n"
"http://[2001:db8::1]:443\n"
"https://[2001:db8::1]:443\n"
"http://[2001:db8::1]:80\n"
"https://[2001:db8::1]:80\n"
"[2001:db8::1]:80\n"
"[2001:db8::1]:443\n"
"2001:db8::1:443\n"
"[2001:db8::1]\n"
"http://[::1]\n"
"https://[::1]\n"
"http://[::1]:80\n"
"https://[::1]:80\n"
"http://[::1]:443\n"
"https://[::1]:443\n"
"[::1]:80\n"
"[::1]:443\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.