import Foundation
let pattern = #"^(http:\/\/|https:\/\/)?[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(:80|:443)?$|^(http:\/\/|https:\/\/)?\[[0-9a-fA-F:]+\](:80|:443)?$|^(http:\/\/|https:\/\/)?[0-9a-fA-F:]+(:80|:443)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://example.com
https://example.com
http://example.com:80
https://example.com:80
http://example.com:443
https://example.com:443
example.com:80
example.com:443
http://10.255.255.1
https://10.255.255.1
http://10.255.255.1:80
https://10.255.255.1:80
http://10.255.255.1:443
https://10.255.255.1:443
10.255.255.1:80
10.255.255.1:443
http://8.8.8.8
https://8.8.8.8
http://8.8.8.8:80
https://8.8.8.8:80
http://8.8.8.8:443
https://8.8.8.8:443
8.8.8.8:80
8.8.8.8:443
8.8.8.8
http://[fd00::1]
https://[fd00::1]
http://[fd00::1]:80
https://[fd00::1]:80
http://[fd00::1]:443
https://[fd00::1]:443
[fd00::1]:80
[fd00::1]:443
fd00::1:80
fd00::1:443
[fd00::1]
fd00::1
http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]
https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]
http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:80
https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:80
http://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:443
https://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:443
2001:0db8:85a3:0000:0000:8a2e:0370:7334:443
http://[2001:db8::1]
https://[2001:db8::1]
http://[2001:db8::1]:443
https://[2001:db8::1]:443
http://[2001:db8::1]:80
https://[2001:db8::1]:80
[2001:db8::1]:80
[2001:db8::1]:443
2001:db8::1:443
[2001:db8::1]
http://[::1]
https://[::1]
http://[::1]:80
https://[::1]:80
http://[::1]:443
https://[::1]:443
[::1]:80
[::1]:443
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)