package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\([^(]*\([^(]*$`)
var str = `(test1(test2(test3
(((((othertest1(othertest2(othertest3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}