re = /\([^(]*\([^(]*$/m
str = '(test1(test2(test3
(((((othertest1(othertest2(othertest3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end