using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([^;]*);){2,3}\1$";
string input = @"NAME;NAME;NAME
NAME;NAME;NAME;NAME
NAME;NAME;NAME;NAME;NAME;NAME
NAME;NAME;NAME;NAME;NAME;NAME;NAME;NAME;NAME
NAME;NAME;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}