$re = '/^(?:([^;]*);){2,3}\1$/m';
$str = 'NAME;NAME;NAME
NAME;NAME;NAME;NAME
NAME;NAME;NAME;NAME;NAME;NAME
NAME;NAME;NAME;NAME;NAME;NAME;NAME;NAME;NAME
NAME;NAME;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);