#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Time[^\n]*|aaa)"
Local $sString = "Time 00:00:01" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"aaa" & @CRLF & _
"..." & @CRLF & _
"Time 00:00:03" & @CRLF & _
"kkk" & @CRLF & _
"kkk" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"lll" & @CRLF & _
"aaa" & @CRLF & _
"aaa" & @CRLF & _
"..." & @CRLF & _
"Time 00:00:04" & @CRLF & _
"kkk" & @CRLF & _
"lll" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")