import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Time[^\\n]*|aaa)";
final String string = "Time 00:00:01\n"
+ "kkk\n"
+ "lll\n"
+ "aaa\n"
+ "...\n"
+ "Time 00:00:03\n"
+ "kkk\n"
+ "kkk\n"
+ "kkk\n"
+ "lll\n"
+ "lll\n"
+ "aaa\n"
+ "aaa\n"
+ "...\n"
+ "Time 00:00:04\n"
+ "kkk\n"
+ "lll\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}