$re = '/^(2(?:2[4-9]|3[0-9]))\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])$/m';
$str = '255.255.255.0
225.3.3.3
255.0.0.0
229.0.0.20
192.168.0.0
8.8.8.8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);