import re
regex = re.compile(r"^(2(?:2[4-9]|3[0-9]))\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])\.([0-2]?[0-9]?[0-9])$", flags=re.MULTILINE)
test_str = ("255.255.255.0\n"
"225.3.3.3\n"
"255.0.0.0\n"
"229.0.0.20\n"
"192.168.0.0\n"
"8.8.8.8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")