#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^address=\/(.*?)\/(\d{1,3}(?:\.\d{1,3}){3})"
Local $sString = "address=/abc.com/0.0.0.0"
Local $sSubst = "local zone: "\1" redirect\nlocal data: "\1 86400 in A \2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)