$re = '/^address=\/(.*?)\/(\d{1,3}(?:\.\d{1,3}){3})/m';
$str = 'address=/abc.com/0.0.0.0';
$subst = "local zone: \"\1\" redirect\nlocal data: \"\1 86400 in A \2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;