package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *\w+(?: +\w+){4,}$`)
var str = `stack over flow
stack over flow stack over`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}