$re = '/^ *\w+(?: +\w+){4,}$/m';
$str = 'stack over flow
stack over flow stack over';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);