package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\-\d{4}\-\d{7}$`)
var str = `test-tes241-text-0123-2-5937-5172473`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}