$re = '/\-\d{4}\-\d{7}$/m';
$str = 'test-tes241-text-0123-2-5937-5172473';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);