import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src\\s*=\\s*\"(.+?)\"";
final String string = "<p>qweq</p>\n\n"
+ "<p>weq</p>\n\n"
+ "<p>we</p>\n\n"
+ "<p>qw</p>\n\n"
+ "<p>e</p>\n\n"
+ "<p>qw</p>\n\n"
+ "<p>e</p>\n\n"
+ "<p><img alt=\"Image title\" class=\"fr-fin fr-dii\" src=\"http://i.froala.com/download/f230c8e0f4dd83433e098c4bafeb3bc9bd12c54c.jpg?1445229186\" width=\"300\"></p><p>asdasdasdqweq qweqwe eqweqweqweqeqe e eqeqweqwe</p><p><img alt=\"Image title\" class=\"fr-fin fr-dii\" src = \"http://i.froala.com/download/f230c8e0f4dd83433e098c4bafeb3bc9bd12c54c.jpg?1445229123\" width= \"300\"></p>\n\n"
+ "<p><br>\n"
+ "</p>\n\n"
+ "<p><br>\n"
+ "</p>\n\n"
+ "<p>qw</p>\n\n"
+ "<p>e</p>\n\n"
+ "<p>q</p>\n\n"
+ "<p>e</p>\n\n"
+ "<p>q</p>\n\n"
+ "<p>e</p>\n\n"
+ "<p>qe</p>\n\n"
+ "<p>q</p>\n\n"
+ "<p>rqtqwt<a href=\"http://qweqweqe\" rel=\"nofollow\" target=\"_blank\">qwtqtqtqwtqw</a></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}