use strict;
my $str = '<p>qweq</p>
<p>weq</p>
<p>we</p>
<p>qw</p>
<p>e</p>
<p>qw</p>
<p>e</p>
<p><img alt="Image title" class="fr-fin fr-dii" src="http://i.froala.com/download/f230c8e0f4dd83433e098c4bafeb3bc9bd12c54c.jpg?1445229186" width="300"></p><p>asdasdasdqweq qweqwe eqweqweqweqeqe e eqeqweqwe</p><p><img alt="Image title" class="fr-fin fr-dii" src = "http://i.froala.com/download/f230c8e0f4dd83433e098c4bafeb3bc9bd12c54c.jpg?1445229123" width= "300"></p>
<p><br>
</p>
<p><br>
</p>
<p>qw</p>
<p>e</p>
<p>q</p>
<p>e</p>
<p>q</p>
<p>e</p>
<p>qe</p>
<p>q</p>
<p>rqtqwt<a href="http://qweqweqe" rel="nofollow" target="_blank">qwtqtqtqwtqw</a></p>';
my $regex = qr/<img.*?src\s*=\s*"(.+?)"/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}