const regex = /^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:729)?\\d+(?:[a-zA-Z])*\\.(?:jpg|png))', 'gm')
const str = `12345.jpg
7290000232.png
0000232.jpg
232.png
000005234abcdef.jpg
abcede23123.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}