import re
regex = re.compile(r"^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))", flags=re.MULTILINE)
test_str = ("12345.jpg\n"
"7290000232.png\n"
"0000232.jpg\n"
"232.png\n"
"000005234abcdef.jpg\n"
"abcede23123.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")