$re = '/(?:")((?:(?:[^"\\\\])*(?:\\\\")*)*)(?:")/';
$str = '"here is a test"
"here \\"is another test\\" done"
"here \\" is \\" a \\" third \\" one "
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);