re = /(?:")((?:(?:[^"\\])*(?:\\")*)*)(?:")/
str = '"here is a test"
"here \\"is another test\\" done"
"here \\" is \\" a \\" third \\" one "
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end