package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,]+, ){5}`)
var str = ` текст1, текст2, текст3, текст4, текст5, текст6, текст7, текст8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}