$re = '/([^,]+, ){5}/m';
$str = ' текст1, текст2, текст3, текст4, текст5, текст6, текст7, текст8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);