#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}Z\b(?<flagE>E[A-Z0-9]{1,4} [A-Z][0-9]{6})|(?<flagW>W [A-Z0-9]{1,4})|[A-Z0-9]{1,4}\b"
Local $sString = "2014-08-29T06:44:03Z X12 IK 888T" & @CRLF & _
" G I5J P9" & @CRLF & _
" 544T ZUK ONI" & @CRLF & _
" E6U5 Z339988 T8 N55" & @CRLF & _
" 886 W 9ZT T95"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")