package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}Z\b(?<flagE>E[A-Z0-9]{1,4} [A-Z][0-9]{6})|(?<flagW>W [A-Z0-9]{1,4})|[A-Z0-9]{1,4}\b`)
var str = `2014-08-29T06:44:03Z X12 IK 888T
G I5J P9
544T ZUK ONI
E6U5 Z339988 T8 N55
886 W 9ZT T95`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}