use strict;
my $str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
';
my $regex = qr/(?(DEFINE)
(?<END>\n\n|$)
(?<LINE>\n.++)
)
(?!.{7}).(*SKIP).(?=(?:....(?&LINE){3,}|..|.(?&LINE)|(?&LINE){2})(?&LINE)(?&END))
|(?<=\n)(*SKIP)..(?=.++(?&LINE){3}(?&END))
|(?<=\n.)(*SKIP)..(?=.++(?&LINE){2}(?&END))
|(?<=\n..)(*SKIP)..(?=.++(?&LINE)(?&END))
|(?<=\n...)(*SKIP)(?=.++(?&END)).+(?=...(?&END))
|(?:(?<=\n....)|(?<=^....))..(*SKIP)(?=.++(?&LINE){4})/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}