import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\babstract\\b)|(\\bassert\\b)|(\\bboolean\\b)|(\\bbreak\\b)|(\\bbyte\\b)|(\\bcase\\b)|(\\bcatch\\b)|(\\bchar\\b)|(\\bclass\\b)|(\\bconst\\b)|(\\bcontinue\\b)|(\\bdefault\\b)|(\\bdouble\\b)|(\\bdo\\b)|(\\belse\\b)|(\\benum\\b)|(\\bextends\\b)|(\\bfalse\\b)|(\\bfinal\\b)|(\\bfinally\\b)|(\\bfloat\\b)|(\\bfor\\b)|(\\bgoto\\b)|(\\bif\\b)|(\\bimplements\\b)|(\\bimport\\b)|(\\binstanceof\\b)|(\\binterface\\b)|(\\bint\\b)|(\\blong\\b)|(\\bnative\\b)|(\\bnew\\b)|(\\bnull\\b)|(\\bpackage\\b)|(\\bprivate\\b)|(\\bprotected\\b)|(\\bpublic\\b)|(\\breturn\\b)|(\\bshort\\b)|(\\bstatic\\b)|(\\bstrictfp\\b)|(\\bsuper\\b)|(\\bswitch\\b)|(\\bsynchronized\\b)|(\\bthis\\b)|(\\bthrows\\b)|(\\bthrow\\b)|(\\btransient\\b)|(\\btrue\\b)|(\\btry\\b)|(\\bvoid\\b)|(\\bvolatile\\b)|(\\bwhile\\b)";
final String string = "void\n"
+ "main\n"
+ "printf\n"
+ "void/\n"
+ "public \n"
+ "scanf\n"
+ "super";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}