import Foundation
let pattern = #"(\babstract\b)|(\bassert\b)|(\bboolean\b)|(\bbreak\b)|(\bbyte\b)|(\bcase\b)|(\bcatch\b)|(\bchar\b)|(\bclass\b)|(\bconst\b)|(\bcontinue\b)|(\bdefault\b)|(\bdouble\b)|(\bdo\b)|(\belse\b)|(\benum\b)|(\bextends\b)|(\bfalse\b)|(\bfinal\b)|(\bfinally\b)|(\bfloat\b)|(\bfor\b)|(\bgoto\b)|(\bif\b)|(\bimplements\b)|(\bimport\b)|(\binstanceof\b)|(\binterface\b)|(\bint\b)|(\blong\b)|(\bnative\b)|(\bnew\b)|(\bnull\b)|(\bpackage\b)|(\bprivate\b)|(\bprotected\b)|(\bpublic\b)|(\breturn\b)|(\bshort\b)|(\bstatic\b)|(\bstrictfp\b)|(\bsuper\b)|(\bswitch\b)|(\bsynchronized\b)|(\bthis\b)|(\bthrows\b)|(\bthrow\b)|(\btransient\b)|(\btrue\b)|(\btry\b)|(\bvoid\b)|(\bvolatile\b)|(\bwhile\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
void
main
printf
void/
public 
scanf
super
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)