#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\-((0[0-9]|1[0-2]):00|0[39]:30)|\+((0[0-9]|1[0-4]):00|(0[34569]|10):30|(0[58]|12):45))"
Local $sString = "-99:99" & @CRLF & _
"-13:00" & @CRLF & _
"-12:45" & @CRLF & _
"-12:30" & @CRLF & _
"-12:15" & @CRLF & _
"-09:15" & @CRLF & _
"+02:15" & @CRLF & _
"+03:44" & @CRLF & _
"+03:45" & @CRLF & _
"+03:46" & @CRLF & _
"+14:15" & @CRLF & _
"+14:45" & @CRLF & _
"+99:99" & @CRLF & _
"-12:00" & @CRLF & _
"-11:00" & @CRLF & _
"-10:00" & @CRLF & _
"-09:30" & @CRLF & _
"-09:00" & @CRLF & _
"-08:00" & @CRLF & _
"-07:00" & @CRLF & _
"-06:00" & @CRLF & _
"-05:00" & @CRLF & _
"-04:00" & @CRLF & _
"-03:30" & @CRLF & _
"-03:00" & @CRLF & _
"-02:00" & @CRLF & _
"-01:00" & @CRLF & _
"-00:00" & @CRLF & _
"+00:00" & @CRLF & _
"+01:00" & @CRLF & _
"+02:00" & @CRLF & _
"+03:00" & @CRLF & _
"+03:30" & @CRLF & _
"+04:00" & @CRLF & _
"+04:30" & @CRLF & _
"+05:00" & @CRLF & _
"+05:30" & @CRLF & _
"+05:45" & @CRLF & _
"+06:00" & @CRLF & _
"+06:30" & @CRLF & _
"+07:00" & @CRLF & _
"+08:00" & @CRLF & _
"+08:45" & @CRLF & _
"+09:00" & @CRLF & _
"+09:30" & @CRLF & _
"+10:00" & @CRLF & _
"+10:30" & @CRLF & _
"+11:00" & @CRLF & _
"+12:00" & @CRLF & _
"+12:45" & @CRLF & _
"+13:00" & @CRLF & _
"+14:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")