# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\-((0[0-9]|1[0-2]):00|0[39]:30)|\+((0[0-9]|1[0-4]):00|(0[34569]|10):30|(0[58]|12):45))"
test_str = ("-99:99\n"
"-13:00\n"
"-12:45\n"
"-12:30\n"
"-12:15\n"
"-09:15\n"
"+02:15\n"
"+03:44\n"
"+03:45\n"
"+03:46\n"
"+14:15\n"
"+14:45\n"
"+99:99\n"
"-12:00\n"
"-11:00\n"
"-10:00\n"
"-09:30\n"
"-09:00\n"
"-08:00\n"
"-07:00\n"
"-06:00\n"
"-05:00\n"
"-04:00\n"
"-03:30\n"
"-03:00\n"
"-02:00\n"
"-01:00\n"
"-00:00\n"
"+00:00\n"
"+01:00\n"
"+02:00\n"
"+03:00\n"
"+03:30\n"
"+04:00\n"
"+04:30\n"
"+05:00\n"
"+05:30\n"
"+05:45\n"
"+06:00\n"
"+06:30\n"
"+07:00\n"
"+08:00\n"
"+08:45\n"
"+09:00\n"
"+09:30\n"
"+10:00\n"
"+10:30\n"
"+11:00\n"
"+12:00\n"
"+12:45\n"
"+13:00\n"
"+14:00\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.