import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)^start$(?!.*^start$).*";
final String string = "total abc total foo total anything here total\n"
+ "total total\n"
+ "total\n"
+ "start\n"
+ "otal abc total foo total anything here total\n"
+ "otal abc total foo total anything here total\n"
+ "start\n"
+ "otal abc total foo total anything here total\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}