const regex = new RegExp('(?ms)^start$(?!.*^start$).*', 'gm')
const str = `total abc total foo total anything here total
total total
total
start
otal abc total foo total anything here total
otal abc total foo total anything here total
start
otal abc total foo total anything here total
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}