package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\h]+\s[^\h]+`)
var str = `Apartment 1 8 Share`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}