$re = '/^[^\h]+\s[^\h]+/';
$str = 'Apartment 1 8 Share';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);