re = /^(?!\(\d{3}\) \d{3}-\d{4})(?:(\+\d{1,2}\s?|\b)?(\(?\d{3}\)?[\s.-]?|\b)\d{3}[\s.-]\d{4}\b)/m
str = '(123) 456-7543
123 456 7832
(456)123-7905
+1(456) 234-1812
+22 (795)372-4902
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end